
บทที่ 2 
ความรู้เบือ้งต้นเก่ียวกับบอร์แลนด์เดลไฟ  

  
   
2.1 ความนํา 
 
 เดลไฟเป็นเคร่ืองมือท่ีใช้พฒันาโปรแกรมบนระบบปฏิบตัิการวินโดว์ โดยใช้โครงสร้าง

ภาษาปาสคาลเป็นหลกัในการพฒันา ซึง่เป็นโครงสร้างภาษาท่ีเขียนง่าย สามารถเห็นผลลพัธ์ท่ีจะ

ได้ตัง้แต่ในขณะท่ีกําลงัสร้าง และถูกใช้พฒันาแอพพลิชนัได้ทุกระดบัทุกประเภทครบถ้วนในตวั

เดียว โดยไมต้่องใช้ภาษาอ่ืนเพิ่มเตมิอีก เน่ืองจากเดลไฟมีเคร่ืองมือช่วยเหลือในการนําคําสัง่ตา่ง ๆ 

ใช้งานได้สะดวกและรวดเร็ว  
 

 เดลไฟเป็นผลิตภณัฑ์ของบริษัทบอร์แลนด์ซอฟต์แวร์ (Borland Software Corporation) 

ซึง่ก่อตัง้ขึน้ในปี ค.ศ. 1980 ตอ่มาได้เปล่ียนช่ือบริษัทเป็นอินไพรส์ (Inprise) ในช่วงปี ค.ศ.1996-

2000 เน่ืองจากประสบภาวะขาดทนุทางธุรกิจ แต่อย่างไรก็ตาม ปัจจบุนัยงัคงใช้ช่ือบริษัทผู้ผลิต

เป็นบอร์แลนด์เช่นเดิมจนถึงเวอร์ชนั 7 ปัจจบุนับริษัทเอ็มบาร์คาเดโร เทคโนโลยี (Embarcadero 

Technologies) ได้ซือ้หุ้น เดลไฟและพฒันามาถึง Delphi XE4  เดลไฟมีคณุสมบตัิเป็นโปรแกรม

ภาษาภาพ (Visual Programming) ซึง่หมายถึง การพฒันาโดยเห็นผลท่ีเกิดขึน้เม่ือรันโปรแกรมได้

ตัง้แตใ่นขณะท่ีกําลงัสร้าง (What you see is what you get : WYSIWYG) โดยการนําชิน้สว่นตา่ง 

ๆ ท่ีต้องการ ซึ่งต่อมาจะถกูเรียกว่า วตัถ ุ(Object) อาทิ ปุ่ ม (Button), ป้ายข้อความ (Label), 

รูปภาพ (Image) เป็นต้น โดยเรียกแหลง่รวมวตัถเุหล่านัน้ว่า องค์ประกอบ (Component) นํามา

วางบนพืน้ท่ีท่ีต้องการนําเสนอบนวินโดว์ เรียกว่า ฟอร์ม (Form) นอกจากนัน้ ยังสามารถ 

รายละเอียดของวตัถไุด้ในคณุสมบตัขิองวตัถ ุ(Property)  และสามารถกําหนดการทํางานของวตัถุ

ได้ในพฤติกรรมของวตัถ ุ(Method) ดงันัน้จึงสรุปได้ว่า Borland Delphi ในหลกัการพฒันา

โปรแกรมในเชิงวตัถท่ีุเรียกวา่ การโปรแกรมเชิงวตัถ ุ(Object Oriented Programming : OOP) 
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2.2 พืน้ฐานเดลไฟ 
  

 เดลไฟเป็นโปรแกรมท่ีใช้การคอมไพเลอร์แปลภาษาโปรแกรมเป็นภาษาเคร่ือง ซึง่ภายหลงั

การคอมไพล์โปรแกรมเราจะได้ไฟล์ท่ีสามารถใช้งานได้ทนัที มีนามสกุล .EXE  ในไฟล์นามสกุล

ดงักล่าวจะเก็บภาษาเคร่ืองไว้เม่ือมีการใช้งานจึงไม่ต้องผ่านขัน้ตอนการแปลงภาษาอีก ทําให้

สามารถทํางานได้เร็ว นอกจากนัน้ความสามารถของเดลไฟท่ีใช้ในการพฒันาแอพพลิเคชนัยงัง่าย

ด้วยการมีคอมโพเนนท์ให้เลือกใช้เป็นจํานวนมาก โดยเดลไฟจดัเก็บคอมโพเนนท์เหล่านัน้อยู่ใน

ห้องสมดุ หรือ คอมโพเนนท์ไลบรารี (component library) ซึง่จะกลา่วตอ่ไปในบทท่ี 4 นอกจากนัน้ 

เดลไฟยงัมีวิซาร์ด (wizard) ท่ีใช้ในการสร้างฟอร์มและออบเจ็คท่ีต้องใช้  บอ่ย ๆ หรือสร้างได้ยาก 

เช่น วิซาร์ดในการสร้างรายงานแบบต่าง ๆ หรือฟอร์มท่ีมีวตัถุประสงค์การใช้ต่างกนั เช่น About 

Box และ Dialog Box เป็นต้น ซึง่เรียกอีกอย่างหนึ่งว่า เทมเพลต (template) สิ่งเหลา่นีช้่วยให้การ

สร้างแอพพลเิคชนัง่ายขึน้ และรวดเร็วขึน้  

 สําหรับการตดิตอ่กบัฐานข้อมลูนัน้ เดลไฟมีคอมโพเนนท์ท่ีสามารถเช่ือมตอ่ เพ่ือให้จดัการ

กบัฐานข้อมลูทุกประเภท เช่น dBase, Paradox, Microsoft Access, SQL Server หรือ 

InterBase เป็นต้น นอกจากนี ้ตัง้แต่เดลไฟเวอร์ชนั 5 ขึน้ไป ยงัเพิ่มคณุสมบตัิในการติดต่อกบั

ฐานข้อมูลด้วย ADO ซึ่งบริษัทไมโครซอฟต์ได้พัฒนาขึน้มาใหม่เพ่ือให้สามารถติดต่อกับ

แหลง่ข้อมลูได้หลายประเภทโดยไมต้่องใช้เคร่ืองของเดลไฟ Borland Database Engine (BDE)  

 เม่ือติดตัง้เดลไฟ มักได้กลุ่มแอพพลิชันช่ือบอร์แลนด์เดลไฟ อยู่ในเมนูโปรแกรมของ

ระบบปฏิบตัิการ ภายในกลุม่จะประกอบด้วยเคร่ืองมือท่ีอํานวยความสะดวกในการบริหารจดัการ

ดงันี ้

 Delphi X  โปรแกรมเดลไฟท่ีใช้พฒันาแอพพลเิคชนั  

 BDE Administrator เค ร่ืองมือ ท่ีใ ช้ กําหนดคุณสมบัติต่าง  ๆ  ในการติดต่อกับ

ฐานข้อมูล ซึ่งการเช่ือมต่อแอพพลิเคชันเข้ากับฐานข้อมูลด้วย 

BDE ซึง่ต้องอาศยั BDE Administrator เป็นตวัช่วยควบคมุการ



เอกสารประกอบการสอนรายวิชา 5671301 

 

2-3 

ทํางานของ BDE เพ่ือให้สามารถใช้งานฐานข้อมูลได้ตาม

ต้องการ 

 Database Desktop เคร่ืองท่ีใช้ในการทํางานกบัฐานข้อมลู  เช่น สามารถฐานช้อมลู 

การตารางจดัเก็บข้อมลู รวมถึงการปรับปรุงข้อมลู ได้แก่ การลบ

ข้อมลู แก้ไขข้อมลู เรียกดขู้อมลู หรือเพิ่มข้อมลู 

 Datapump  เคร่ืองมือท่ีใช้ย้ายข้อมลูจากฐานข้อมลูหนึง่ ไปฐานข้อมลูหนึง่ 

 Database Explorer เคร่ืองมือท่ีใช้เรียกดรูายละเอียดในฐานข้อมลูทัง้โครงสร้างการ

ออกแบบและรายการข้อมลูในตารางข้อมลู  

 SQL Monitor เคร่ืองท่ีใช้ในการติดต่อดูการติดต่อระหว่าง BDE และ 

Database Server ว่ามีการส่งคําสัง่ SQL อะไรไปบ้าง ซึ่ง

เคร่ืองมือนีมี้เฉพาะในเดลไฟ แบบ Enterprise Edition เท่านัน้ 

 Image Editor เคร่ืองมือท่ีใช้ในการตกแตง่ภาพ 

 WinSight32 เคร่ืองมือท่ีใช้ตรวจดกูารทํางานของโปรแกรมท่ีเราเขียนขึน้ ว่ามี

การตดิตอ่อะไรกบัระบบปฏิบตักิารอยูบ้่าง 

 Help สว่นท่ีใช้แสดงรายละเอียดในการใช้งานโปรแกรมเดลไฟทัง้หมด 

  

2.3 สภาพแวดล้อมของเดลไฟ 
 

การสร้างโปรแกรมในเดลไฟจะมีรูปแบบท่ีเรียกว่า Integrated Development 

Environment (IDE) คือเป็นการสร้างโปรแกรมโดยการทํางานทกุอย่างสามารถทําได้จากท่ีแห่ง

เดียวกนัโดยไม่จําเป็นต้องใช้แอพพลิเคชนัตวัหนึ่งเขียนโค้ด และคอมไฟล์ด้วยแอพพลิเคชนัอีกตวั

หนึง่ หรือ Command Line ภายนอก ซึง่ทําให้การพฒันาโปรแกรมทําได้สะดวกมากยิ่งขึน้ 
 

2.3.1 ส่วนประกอบภายในสภาพแวดล้อม 
 

เม่ือเรียกใช้โปรแกรมเดลไฟแล้วจะเห็นหน้าตาโปรแกรมซึ่งประกอบด้วย
วินโดว์ตา่ง ๆ ดงัรูปท่ี 2.1 
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รูปที่ 2.1 สภาพแวดล้อมของเดลไฟ 
 

ส่วนที่ 1 วินโดว์หลัก (Main Window) วินโดว์หลกัทําหน้าท่ีเป็นตวักลาง

สําหรับควบคมุกระบวนการในการพฒันาโปรแกรม ไม่ว่าจะเป็นการจดัการเก่ียวกับไฟล์ภายใน

แอพพลิเคชนั การคอมไพล์ การตรวจสอบข้อผิดพลาด เม่ือรันโปรแกรมเดลไฟจะเห็นวินโดว์หลกั

เป็นวินโดว์ท่ีอยู่บนสดุ โดยภายในวินโดว์หลกัจะแบง่เป็น 4 สว่น คือ  ไตเติลบาร์ เมนบูาร์  สปีด-

บาร์ และ ทลูบาร์ 

 

 

 
รูปที่ 2.2 วินโดว์หลกัของเดลไฟ 

 
 ไตเตลิบาร์ (Title Bar) 

เป็นสว่นท่ีอยูบ่นสดุ แสดงช่ือโปรแกรมเดลไฟ และช่ือโปรเจ็ค (Project) ท่ีทํางานอยู่
ขณะนัน้ 
 

ส่วนท่ี 1 

 

ไตเติลบาร์ เมนูบาร์ 

สปีดบาร์ ทูลบาร์ 

ส่วนท่ี 2 

ส่วนท่ี 3 ส่วนท่ี 4 
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 เมนูบาร์ (Menu Bar) 

เป็นส่วนประกอบท่ีจะพบได้ในแอพพลิเคชันบนวินโดว์ทั่วไป โดยจะอยู่ใต้ไตเติล

บาร์ ภายในเมนบูาร์จะแสดงเมนคํูาสัง่ของเดลไฟ ท่ีใช้ทํางานทัง้หมด อาทิ เมน ูFile 

Edit Search Views Project เป็นต้น ซึง่แตล่ะเมนจูะมีคําสัง่ย่อยภายในแสดงใน

ลกัษณะ DropDown เม่ือคลกิหวัข้อเมน ู

 สปีดบาร์ (Speed Bar) 

เป็นสว่นแสดงกลุม่คําสัง่ของเมนบูาร์ท่ีถกูใช้บอ่ย ๆ ด้วยการใช้ปุ่ มแทนรายการ เม่ือ

คลิกเมาส์ท่ีปุ่ มใดจะเหมือนกับการเลือกคําสัง่ในเมนูบาร์ และเม่ือเล่ือนเมาส์ไป

หยดุบนปุ่ มใดจะเห็น กรอบข้อความปรากฏ (tooltips) แสดงช่ือเมนแูละฟังก์ชนัคีย์

ท่ีเป็นคีย์ลดัสําหรับใช้แทนปุ่ มนัน้  

ปุ่ มทีค่วรทราบในการใชง้าน 

    New : ใช้ในกรณีต้องการสร้างโปรเจ็คใหม ่

    Open : ใช้ในกรณีเรียกโปรเจ็คเดมิเพ่ือปรับปรุงแก้ไข 

    Save และ Save Alll : ใช้ในกรณีต้องการจดัเก็บงาน 

    View Unit : ใช้ในกรณีเลือกแสดง Dialog Code ของ Unit 

    View Form : ใช้ในกรณีเลือกแสดง Form ของ Unit 

    Toggle Form : ใช้ในกรณีแสดง Form ของ Unit ปัจจบุนั 

    New Form : ใช้ในกรณีสร้าง Form และ Unit ใหม ่

    Run : ใช้ในกรณีประมวลผลโปรเจ็คปัจจบุนั 

 

 ทลูบาร์ (Toolbar) หรือ คอมโพเนนต์พาเล็ต (Component Palette) 

เป็นส่วนท่ีเคร่ืองมือท่ีใช้สร้างและตกแต่งแอพพลิเคชนั โดยจดักลุ่มเคร่ืองมือไว้ใน

แท็บตา่ง ๆ อาทิ Standard, Additional, Win32, System เป็นต้น ซึง่เม่ือคลิกแท็บ

เพ่ือแสดงคอมโพเนนท์ในแต่ละกลุ่ม และเล่ือนเมาส์ไปหยดุในคอมโพเนน์ตวัใดตวั

หนึง่จะปรากฏกรอบข้อความแสดงช่ือทลูดงักลา่วขึน้ทางจอภาพ 
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ส่วนที่ 2  วินโดว์ออบเจ็คอินสเป็คเตอร์ (Object Inspector Window)

วินโดว์ออบเจ็คอินสเป็คเตอร์เป็นวินโดว์ซึ่งอยู่ใต้วินโดว์หลกัทางด้านซ้าย ใช้สําหรับแสดงและ

ปรับแต่งค่าคณุสมบตัิ (Property) และเหตกุารณ์ (event) ของคอมโพเนนท์  ซึ่งคณุสมบตัิท่ี

ปรากฏในปัจจบุนัขึน้อยู่กบัเรากําลงัทํางานอยู่ท่ีคอมโพเนนท์ใด ดงัเช่นรูปท่ี 1 จากรูปจะเห็นว่าใต้

ไตเตลิบาร์ของวินโดว์ออบเจ็คอินสเป็คเตอร์ ใช้สําหรับแสดงช่ือ และชนิดของคอมโพเนนท์ท่ีทํางาน

อยู่ขณะนัน้ “Form1 : TForm1” แสดงว่าเรากําลงัทํางานกบัคอมพิวเตอร์ช่ือ Form1 และมีชนิด

คอมโพเนนท์เป็น TForm1 สว่นถดัลงมาปรากฏงาน 2 แท็บ คือ Properties และ Events สําหรับ

การดําเนินงานดงันี ้
 

 คุณสมบัต ิ( Properties ) 

ใช้กําหนดคณุสมบตัิของคอมโพเนนท์ โดยภายในแท็บแบง่ออกเป็น 2 คอลมัน์ โดย

คอลมัน์ด้านซ้ายแสดงช่ือของคณุสมบตัิ เช่น Font, color, caption เป็นต้น สว่น

คอลมัน์ด้านขวาแสดงคา่ของคณุสมบตันิัน้ท่ีสามารถแก้ไขปรับปรุงได้ 

 เหตุการณ์ ( Events ) 

ใช้กําหนดการทํางานเม่ือมีเหตกุารณ์หรือการกระทําใด ๆ เกิดขึน้กบัคอมโพเนนท์

ดงักลา่ว ซึง่อาจเกิดจากกระทําของผู้ใช้ (จงใจให้เกิด) หรือตวัโปรแกรมเอง เช่น การ

ใช้เมาส์คลกิ การกดคีย์ Enter การแก้ไขเปล่ียนแปลงคา่ การเคลื่อนท่ีของเมาส์ เป็น

ต้น 
 

ส่วนที่ 3  วินโดว์ฟอร์ม (Form Window) ฟอร์มเป็นวินโดว์ท่ีใช้สําหรับ

ออกแบบบส่วนท่ีติดต่อกบัผู้ ใช้ (Users Interface) โดยการนําคอมโพเนนท์ต่าง ๆ จาก Toolbar 

มาวางลงบนฟอร์ม ซึ่งการวางและปรับแต่งคณุสมบตัิคอมโพเนนท์ดงักล่าว หากประมวลผลโปร

เจ็ค (Run) ผลท่ีได้รับทางจอภาพจะมีลกัษณะเดียวกนั  อย่างไรก็ตาม โปรเจ็คหนึ่ง ๆ ของเดลไฟ 

มกัมีการสร้าง Form มากกว่า 1 ฟอร์มเสมอ ดงันัน้ Delphi จึงกําหนดให้เร่ิมต้นการแสดงท่ี Form 

แรกเสมอ หากต้องการแสดง Form อ่ืน ๆ ต้องเขียนโค้ดสัง่ให้แสดง Form ดงักลา่วเองผา่น Events 
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ส่วนที่ 4  วินโดว์โค้ดเอดิเตอร์ (Code Editor Window) วินโดว์โค้ดเอติ

เตอร์มีไว้สําหรับเขียนโปรแกรม โดยอาจจะถูกบงัคบัให้แสดงอยู่ใต้ฟอร์ม เม่ือเล่ือนวินโดว์ฟอร์ม

ออกไปหรือคลิกปุ่ ม Minimize ฟอร์ม จะปรากฏวินโดว์โค้ดเอดิเตอร์ขึน้ ซึ่งการเขียนโค้ดสําหรับ

ควบคมุการทํางานของโปรเจ็คและฟอร์ม สามารถเขียนได้ผ่าน Events ของคอมโพเนนท์ หรือ

เขียนขึน้ใหม่ตามความต้องการในรูปโปรแกรมย่อย (Sub-program) ท่ีมี 2 รูปแบบ Procedure 

หรือ Function ซึง่จะกลา่วตอ่ไปในหวัข้อท่ี 4 

  
2.3.2 เคร่ืองมือหยั่งรู้ (Code Insight) 

 

เพ่ือลดข้อผิดพลาดและเพิ่มความสะดวกรวดเร็วในการเขียนโปรแกรม  
เดลไฟเตรียมเคร่ืองมือท่ีเรียกว่า Code Insight ช่วยอํานวยความสะดวกในการเขียนโค้ด 
ประกอบด้วย 

 Code Completion ใช้สําหรับแสดงคณุสมบตัิ พฤติกรรม หรือเหตกุารณ์
ของออบเจ็คให้เลือก โดยค่าเหล่านีจ้ะแสดงขึน้มาหลงัจากท่ีคีย์ช่ือออบเจ็คแล้วตามด้วยจุด เช่น 
ถ้าโปรแกรมมีออบเจ็คช่ือ Form1 ซึง่เป็นออบเจ็คประเภท TForm เม่ือคีย์คําว่า Form1. แล้วรอ
สักครู่จะปรากฏรายการพฤติกรรม
และคณุสมบตัิของ Form1 ขึน้มาให้
เลือกในลักษณะกล่องรายการ เม่ือ
เลือกแล้วกดคีย์ Enter ค่าท่ีเลือกจะ
ถกูเขียนลงโค้ดเอดเิตอร์ให้ทนัที 

 

Code Parameter ใช้สําหรับแสดงพารามิเตอร์ของโพรซีเยอร์หรือฟังก์ชนั
เม่ือคีย์ช่ือโพรซีเยอร์หรือฟังก์ชันตาม
ด้วยวงเล็บเปิด จะมีข้อความเล็ก ๆ 
ปรากฏช่ือพารามิเตอร์พร้อมชนิดตัว
แปรตรงตําแหน่งของเคเซอร์ เพ่ือช่วย
ใ ห้ผู้ ใ ช้ ใส่ค่าพารามิ เตอ ร์ไ ด้อย่าง
ถกูต้อง 
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Code Templates ใช้สําหรับเรียกใช้คําสัง่จากเทมเพลต ซึง่เดลไฟจะเก็บ
โครงสร้างของคําสัง่ต่าง ๆ ไว้ โดยท่ีเราสามารถเพิ่มเติมหรือลบคําสัง่ในเทมเพลตได้ การใช้งานก็
เพียงแต่คีย์ตวัอกัษรของคําสัง่จากนัน้
กดคีย์ Ctrl+J จะปรากฏรายการของ
คําสัง่ในโค้ดเทมเพลตให้เลือก เม่ือกด
คีย์ Enter โครงสร้างคําสัง่ดงักล่าวจะ
ถูกเขียนเป็นโครงร่างในโค้ดเอดิเตอร์
ทนัที 

2.3.3 การกาํหนดสภาพแวดล้อมในการพัฒนา 
 

สภาพแวดล้อมของเดลไฟสามารถยืดหยุ่นต่อการใช้งานมาก เราสามารถ

ปรับแตง่เพ่ือสะดวกแก่การใช้งานก่อนจะเร่ิมสร้างแอพพลเิคชนั โดยมีหวัข้อท่ีควรให้ความสําคญั 2 

หวัข้อ ได้แก่ 

Environment Options การเปล่ียนแปลงสภาพแวดล้อมในการทํางานปกต ิ

โดยเลือกจากเมน ูTools > Environment Options จะปรากฏไดอะล๊อกบ๊อกซ์ Environment 

Options สําหรับการปรับแตง่สภาพแวดล้อมทัว่ไปจะรวมกนัอยู่ในหวัข้อ Preferences โดยในหน้า

นีจ้ะมีคา่ให้กําหนดมากมาย แตมี่รายการท่ีควรพิจารณาหลกั ๆ คือ 

 Autosave Options กําหนดให้บนัทึกข้อมลูโดย

อตัโนมตัิ ซึ่งจะมีค่าให้กําหนด 2 ค่า คือ Editor 

Files คือการบนัทึกโปรเจ็คให้โดยอตัโนมตัิทกุครัง้

ก่อนจะรัน และ Project Desktop คือการบนัทก

ขนาดและตําแหน่งของวินโดว์ต่าง ๆ รวมทัง้

รายการไฟล์ท่ีเปิดอยู่ก่อนท่ีจะออกจากโปรแกรม

เดลไฟ 

 Form Designer กําหนดรูปแบบการจดัเก็บข้อมลู

ฟอร์ม ซึง่มี 2 รูปแบบคือ New Form as Text 

หมายถึงกําหนดให้บนัทึกหน้าตาของฟอร์มใหม่ท่ี
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สร้างขึน้ (ไฟล์ .dfm) ในแบบข้อความแทนแบบไบนารี และ Auto Create Forms หมายถึง

กําหนดให้เพิ่มคําสัง่สร้างฟอร์มไว้ในโปรเจ็คเลยหรือใหม่ หรือจะต้องเขียนโค้ดเพ่ือสร้างฟอร์ม

เอง 

Editor Options การปรับเปลี่ยนสภาพแวดล้อมด้านเอดิเตอร์ท่ีใช้สําหรับ

เขียนชุดคําสั่ง เช่น การกําหนดระยะช่องไฟ การปรับ

ขนาดตวัหนงัสือ รูปแบบตวัหนงัสือ สีท่ีแสดง เป็นต้น โดย

เลือกจากเมน ูTools > Editor Options จะปรากฏ

ไดอะล๊อกบ๊อกซ์ท่ีมีหวัข้อดงัตอ่ไปนี ้

 General กําหนดรูปแบบของโค้ดเอดิเตอร์ เช่น การ

กําหนดระยะห่างของช่องไฟท่ีได้จากการกดคีย์ Tab 

เป็นต้น 

 Display กําหนดรูปแบบของอกัษรและสีท่ีต้องการใช้ในวินโดว์เอดเิตอร์ 

 Key Mappings กําหนดคีย์ตา่ง ๆ ท่ีใช้ในการแก้ไขโค้ด 

 Color  กําหนดสีของคําสัง่ตา่ง ๆ ในวินโดว์โค้ดเอดเิตอร์ 

 Code Insight  กําหนดคณุสมบตัิของ Code Insight ท่ีเก่ียวกบั Code Completion, Code 

Parameters และ Code Templates ดงัท่ีกลา่วไว้แล้ว 

 
2.4 ขัน้ตอนการพฒันาโปรแกรม 

 
การพฒันาแอพพลิเคชนัด้วยเดลไฟเป็นสิ่งท่ีทําได้ง่าย เน่ืองจากเดลไฟเป็นโปรแกรมเชิง

ภาพท่ีมีสภาพแวดล้อมและคอมโพเนนท์ท่ีอํานวยความสะดวกต่อผู้ ใช้ ทําให้การพฒันาไม่ยุ่งยาก

ซับซ้อนโดยมีขัน้ตอนหลัก ๆ ตามลําดับดังนี  ้สร้างโปรเจ็คใหม่ วางคอมโพเนนท์ลงบนฟอร์ม 

กําหนดค่าคุณสมบตัิและพฤติกรรม กําหนดเหตุการณ์และ/หรือเขียนคําสัง่ควบคุมการทํางาน 

บนัทึกโปรเจค และ ประมวลผลโปรแกรม  จนกระทัง่ปิดโปรแกรมและสามารถเปิดขึน้มาใหม่เพ่ือ

ดําเนินการพฒันาต่อเน่ือง ซึง่ขัน้ตอนหลกัท่ีกลา่วข้างต้น เราสามารถอธิบายโดยพฒันาโปรแกรม

ตวัอยา่งการทกัทายได้ตามลําดบัดงันี ้
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2.4.1 สร้างโปรเจค็ใหม่ 
 

เ ม่ือเราต้องการสร้างแอพพลิ เคชันใหม่ ด้วยการเลือกหัว ข้อ  New 

Application ในเมนบูาร์แล้ว เดลไฟ

จะจัดการสร้างโปรเจ็ค (Project) 

ให้หนึ่ง โปรจ็ค  ซึ่งประกอบด้วย 

ฟอร์มหนึ่งฟอร์ม และยนิูตหนึ่งยนิูต 

ดังนัน้โปรเจ็คหนึ่งก็คือแอพพลิเค

ชันนั่นเอง โดยปกติแล้วเม่ือมีการ

สร้างโปรเจ็คใหม่ทุกครัง้ เดลไฟจะ

ตัง้ช่ือเป็นมาตรฐานไว้เสมอได้แก่ 

โปรเจ็คช่ือ Project1 ฟอร์มช่ือ Form1 และยนิูตช่ือ Unit1  
 

2.4.2 วางคอมโพเนนท์ลงบนฟอร์ม 
 

เม่ือเราสร้างโปรเจ็ค

ใหม่ขึน้มาแล้วในขัน้ตอนตอ่มาคือการสร้าง

ส่วน ท่ีติดต่อกับผู้ ใ ช้  โดยการวางคอม

โพเนนท์ลงบนฟอร์มตามต้องการ ซึ่งขึน้อยู่

กบัการออกแบบและความจําเป็นในการใช้

งาน ในท่ีนีเ้ราจะสร้างการทกัทายจงึต้องใช้คอมโพเนนท์ของบางกลุม่ตามลําดบัดงันี ้

(1) คลกิกลุม่คอมโพเนนท์ช่ือ Standard 

(2) เลือกคอมโพเนนท์ Label  

(3) จากนัน้คลกิลงบนฟอร์ม ณ ตําแหน่งท่ีต้องการวาง 

(4) เลือกคอมโพเนนท์ Edit  

(5) จากนัน้คลกิลงบนฟอร์ม ณ ตําแหน่งท่ีต้องการวาง 

(6) เลือกคอมโพเนนท์ Button 

 

 



เอกสารประกอบการสอนรายวิชา 5671301 

 

2-11 

(7) จากนัน้คลกิลงบนฟอร์ม ณ ตําแหน่งท่ีต้องการวาง 

(8) ปรับแตง่ตําแหน่งของคอมโพเนนท์ตามต้องการได้ในภายหลงั 
 

ซึง่การวางคอมโพเนนท์บนฟอร์มเป็นการสร้าง Instance ของออบเจ็ค

นัน้ เช่น คอมโพเนนท์ Edit เม่ือนํามาวางบนฟอร์มก็จะได้ Instance ของออบเจ็คชนิด Edit เป็นต้น 

ซึง่กรณีท่ีมีการใช้คอมโพเนนท์ชนิดเดียวกนัมากกว่า 1 ตวัก็จะมีการสร้าง Instance ของออบเจ็ค

ขึน้ใหมต่ามจํานวนท่ีใช้จริง  

 
2.4.3 กาํหนดค่าคุณสมบัตแิละพฤตกิรรม 

 

เม่ือเรานําคอมโพเนนท์ต่าง ๆ มาวางลงบนฟอร์มแล้ว ต่อไปจะต้องการ

กําหนดคณุสมบตัิให้กบัคอมโพเนนท์แต่ละ

ตัวด้วย  เ พ่ือให้ส่วนท่ีติดต่อกับผู้ ใ ช้ นี มี้

ลักษณะสมบู ร ณ์ ขึ น้  ซึ่ ง ก า ร กํ าหนด

คุณสมบตัิของคอมโพเนนท์ก็คือการให้ค่า

คุณสมบัติแก่ออบเจ็คซึ่งแสดงอยู่ในวินโดว์ออบเจ็คอินสเป็คเตอร์นั่นเอง เราจะกําหนดค่า

คณุสมบตัใิห้กบัออบเจ็คท่ีอยูบ่น Form1 ดงันี ้

(1) คลกิท่ีคอมโพเนนท์ Label ท่ีอยูบ่นฟอร์ม 

(2) พิจารณาในวินโดว์ออบเจ็คอินสเป็คเตอร์ปรากฏช่ือคอมโพเนนท์ว่า 

Label1.TLabel เพ่ือกําหนดคา่คณุสมบตั ิCaption  

(3) ลบคา่คณุสมบตัปัิจจบุนัออกและระบคุา่ใหมว่า่  “กรุณาระบช่ืุอ”  

(4) คลกิท่ีคอมโพเนนท์ Edit ท่ีอยูบ่นฟอร์ม 

(5) พิจารณาในวินโดว์ออบเจ็คอินสเป็คเตอร์ปรากฏช่ือคอมโพเนนท์ว่า 

Edit1.TEdit เพ่ือกําหนดคา่คณุสมบตั ิText  ให้เป็น “-”  

(6) คลกิท่ีคอมโพเนนท์ Button ท่ีอยูบ่นฟอร์ม 

(7) พิจารณาในวินโดว์ออบเจ็คอินสเป็คเตอร์ปรากฏช่ือคอมโพเนนท์ว่า 

Button1.TButton เพ่ือกําหนดคา่คณุสมบตั ิCaption ให้เป็น “ทกัทาย”  
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2.4.4 กาํหนดค่าเหตุการณ์และ/หรือเขียนคาํส่ังควบคุมการทาํงาน 
 

เม่ือเราได้หน้าตาของแอพพลิเคชนัแล้ว ตอ่ไปจะเป็นการเพ่ิมคําสัง่ควบคมุ

การทํางานให้แอพพลิเคชนัให้สามารถโต้ตอบกบัผู้ ใช้งานได้ โดยกําหนดการทํางานไว้ว่า ถ้าผู้ ใช้

ป้อนช่ือใน Edit1 บนฟอร์มแล้วคลิกปุ่ ม ทกัทาย แล้วให้ปรากฏข้อความว่า “สวสัดี..คณุ(ช่ือท่ี

ป้อน)” บนจอภาพ ซึง่เราสามารถเขียนคําสัง่ควบคมุการทํางานได้ดงันี ้

(1) คลกิคอมโพเนนท์ Button  

(2) พิจารณาในวินโดว์ออบ

เจ็คอินสเป็คเตอร์ปรากฏ

ช่ื อ ค อ ม โ พ เ น น ท์ ว่ า 

Button1.TButton  จาก 

นั น้ คลิ ก ท่ี แ ท็บ  Events 

เพ่ือกําหนดเหตกุารณ์ 

(3) ดบัเบิล้คลิกท่ีช่องว่างด้านขวาของเหตกุารณ์ OnClick เพ่ือให้ปรากฏ

ช่ือ Button1Click และเดลไฟจะจดัการสร้างโพรซีเยอร์ดงักล่าวไว้ใน

วินโดว์โค้ดเอดิเตอร์เพ่ือให้เราเขียนคําสัง่ควบคมุลงไประหว่าง Begin 

และ End; 

(4) เขียนคําสัง่ระหวา่ง Begin End; ดงันี ้
 

2.4.5 บันทกึโปรเจค็ 
 

การบนัทึกโปรเจ็คเป็นการจดัเก็บข้อมลูท่ีเราสร้างขึน้มา ซึ่งควรจะบนัทึก

โปรเจ็คก่อนประมวลผลโปรแกรมเสมอ เพราะหากเกิดข้อผิดพลาดจะทําให้ไม่สามารถทํางานกบั

เดลไฟได้ต่อไป ในการจัดเก็บข้อมูลของโปรเจ็คหนึ่ง ๆ แบ่งออกเป็นหลายไฟล์ ซึ่งเดลไฟจะ

กําหนดการจดัเก็บหลกั ๆ ตามช่ือไฟล์ได้แก่  ไฟล์ท่ีบนัทึกข้อมลูของยนิูตคือ ช่ือยนิูต(.pas) ไฟล์ท่ี

บนัทึกรายละเอียดของโปรเจ็คคือ ช่ือโปรเจ็ค(.dpr)  ซึง่ช่ือของไฟล์ต้องไม่เหมือนกนั ดงัขัน้ตอน

ตอ่ไป 
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(1) คลกิเมน ูFile > Save All 

(2) เลือกไดเร็คทอรีท่ีต้องการบนัทกึโปรเจ็ค  

(3) ใสช่ื่อยนิูตในช่อง File name โดยปกตเิป็น Unit1 คลกิปุ่ ม Save 

(4) กรณีท่ีมีการสร้างงานหลายยนิูตจะปรากฏให้ใสช่ื่อยนิูตตามจํานวน 

(5) ใสช่ื่อโปรเจ็คในช่อง File name โดยปกตเิป็น Project1 คลกิปุ่ ม Save 

 
2.4.6 ประมวลผลโปรแกรม 

 

การคอมไพล์เป็นการตรวจสอบว่าคําสั่งต่างๆ ท่ีเราเขียนขึน้นัน้ถูกต้อง

หรือไม่ และสร้างไบนารีไฟล์ (.dcu) ขึน้มา ซึ่งกรณีท่ีมีการบนัทึกโปรแกรมก่อนประมวลผล

โปรแกรม และโปรแกรมไม่พบข้อผิดพลาดใด ๆ เดลไฟจะสร้างไฟล์ .exe ท่ีมีช่ือเดียวกบัโปรเจ็ค

วิธีการคอมไพล์โปรแกรมสามารถทําได้ดงันี ้

(1) คลิกเมนู Project > Compile 

(ปรากฏช่ือไฟล์โปรเจ็คปัจจบุนั) หรือ 

(2)  คลกิเมน ูRun > Run หรือ 

(3)  คลกิปุ่ ม Run ใน สปีดบาร์  

 

 
 

2.4.7 การปิด/เปิดโปรแกรม 
 

เม่ือเสร็จสิน้การพฒันาสามารถปิดไฟล์/โปรเจ็คโดยมีทางเลือก 2 ทาง คือ 

(1) คลกิเมน ูFile > Close  เพ่ือปิดฉพาะไฟล์ท่ีแสดงอยูใ่นขณะนัน้ หรือ 

(2) คลิกเมน ูFile > Close All เพ่ือปิดทกุไฟล์ท่ีทํางานอยู่ในขณะนัน้

รวมทัง้โปรเจ็คด้วย 

ส่วนการเปิดโปรเจ็คเม่ือต้องการพฒันาต่อหรือปรับปรุงแก้ไข มีคําสัง่ให้

เลือก 3 ทาง คือ 
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(1) คลิกเมนู File > Open เพ่ือเปิดไฟล์ท่ีเก็บไว้ขึน้มาทํางาน ซึ่งจะ

สามารถเปิดได้ทัง้โปรเจ็ค (.dpr) ฟอร์ม (.dfm) และยนิูต (.pas)  

(2) คลิกเมน ูFile > Open Project เพ่ือเปิดโปรเจ็ค (.dpr) ท่ีบนัทึกไว้

ขึน้มาทํางาน  

(3) คลกิเมน ูFile > Reopen เพ่ือเปิดไฟล์ (.pas) หรือโปรเจ็ค (.dpr) ท่ีเพิ่ง

ปิดไปขึน้มาทํางาน 

    

2.5 ประเภทไฟล์ของเดลไฟ 
 

 ในโปรเจ็คหนึง่ ๆ ท่ีเราสร้างขึน้จะประกอบไปด้วยไฟล์ตา่ง ๆ ท่ีมีหน้าท่ีและการทํางานท่ี

แตกตา่งกนั บางไฟล์ถกูสร้างขึน้ตอนออกแบบ บางไฟล์ถกูสร้างขึน้หลงัจากการบนัทกึ และบาง

ไฟล์ถกูสร้างขึน้ในขณะทําการคอมไฟล์โปรเจ็ค ซึง่แตล่ะไฟล์มีการทํางานหลกั ๆ ดงัตอ่ไปนี ้
 

2.5.1 ไฟล์โปรเจค็ (Project File) 
    

 คือไฟล์ท่ีรวบรวมรายละเอียดของโปรเจ็ค ว่าภายในโปรเจ็คหนึ่งนัน้

ประกอบด้วยฟอร์มหรือยูนิตอะไรบ้าง 

นอกจากนีย้ังทําหน้าท่ีสร้างฟอร์มและ

เรียกฟอร์มหลักของแอพพลิเคชันขึน้มา

ทํางานอีกด้วย ในแอพพลิเคชนัหนึ่ง ๆ จะ

มีโปรเ จ็คไฟล์เพียงไฟล์เดียว   โดยมี

นามสกลุเป็น .dpr และจะถกูสร้างขึน้เม่ือ

เราสร้างโปรเจ็คใหม่ ซึ่งถ้าเป็นโปรเจ็คแรก เดลไฟจะกําหนดช่ือมาตรฐานสําหรับโปรเจ็คเป็น 

Project1.dpr และเม่ือคอมไฟล์โปรเจ็คเราจะได้ไฟล์ .exe ท่ีมีช่ือเดียวกบัโปรเจ็คไฟล์ 
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2.5.2 ยูนิตไฟล์ (Unit File) 
    

 คือไฟล์ท่ีจัดเก็บมอดูลย่อยของโปรแกรม เรียกว่า ยูนิต (Unit) ซึ่งแต่ละ       

ยูนิตจะเก็บรายละเอียดของตัวแปร ค่าคงท่ี ชนิดข้อมูล โพรซีเยอร์ และฟังก์ชัน เพ่ือใช้ในการ

ทํางานภายในยนิูตนัน้ ๆ ปกติเดลไฟ จะกําหนดให้ยูนิตไฟล์มีนามสกุลเป็น .pas ซึ่งความจริง

สามารถกําหนดเป็นนามสกลุอ่ืนก็ได้ เพียงแต่ .pas เป็นนามสกุลมาตรฐานของภาษาปาสกาล 

หลังจากคอมไฟล์หรือรันโปรเจ็ค เดลไฟจะสร้างไบนารีไฟล์ให้สําหรับแต่ละยูนิต โดยมีช่ือ

เหมือนกบัช่ือยนิูตไฟล์แตมี่นามสกลุเป็น .dcu  
  

 โดยปกตฟิอร์มหนึง่ ๆ จะประกอบด้วยยนิูตไฟล์หนึ่งไฟล์ ซึง่ทํางานสมัพนัธ์

กบัฟอร์มนัน้ โดยสิง่ท่ีอยูใ่นยนิูตฟอร์มมีโครงสร้างดงันี ้

 
unit Unit1; 
interface 
uses 
  Windows, Messages, SysUtils, Variants, Classes, Graphics, Controls, Forms,  Dialogs, 
StdCtrls; 
type 
  TForm1 = class(TForm) 
    Label1: TLabel; 
    Edit1: TEdit; 
    Button1: TButton; 
    procedure Button1Click(Sender: TObject); 
  private 
    { Private declarations } 
  public 
    { Public declarations } 
  end; 
var 
  Form1: TForm1; 
implementation 
{$R *.dfm} 
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                procedure TForm1.Button1Click(Sender: TObject); 
begin 
    Showmessage('สวสัดี..คณุ'+Edit1.text); 
end; 
end. 

 

 
2.5.3 ฟอร์มไฟล์ (From File) 

    

 เดลไฟจะเก็บรายละเอียดของออบเจ็คท่ีอยู่บนฟอร์มรวมทัง้ตวัฟอร์ม เช่น 

คณุสมบตัิของฟอร์ม คณุสมบตัิ

ของคอมโนเนนท์ท่ีอยู่บนฟอร์ม 

เป็นต้น โดยแยกเก็บไว้ในอีก

ไฟล์ต่างหาก เม่ือเราบนัทึกโปร

เจ็ค เดลไฟจะสร้างโดยให้มีช่ือ

เหมือนกับยูนิต แต่มีนามสกุล

เป็น .dfm ซึ่งสามารถดู

รายละเอียดของไฟล์นีไ้ด้โดย

คลิกเมาส์ขวาบนฟอร์มแล้ว

เลือก View as Text จะปรากฏ

หน้าตาของฟอร์มไว้ดงัรูป เม่ือคลิกเมาส์ขวาและเลือก View as Text อีกครัง้ก็จะกลบัมายงัวินโดว์

ปกต ิ
 
 
 

2.5.4 ไฟล์ทรัพยากร (Resource File) 
    

 เป็นรูปแบบการเก็บข้อมลูท่ีใช้สําหรับวินโดว์ ซึง่ปกตจิะใช้เก็บสว่นประกอบ

ตา่ง ๆ ท่ีเป็นไบนารี เช่น ไอคอนของแอพพลิเคชนัท่ีเรากําหนดในไดอะล็อกบ๊อกซ์ Project Option 

เป็นต้น โดยปกตเิม่ือเราสร้างโปรเจ็ค เดลไฟจะสร้างไฟล์นีใ้ห้หนึ่งไฟล์โดยใช้ช่ือเดียวกบัช่ือโปรเจ็ค 
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แตมี่นามสกลุเป็น  .res เพ่ือใช้สําหรับจดัเก็บไอคอนท่ีกําหนดไว้ใน Project Option และใสไ่ว้ใน

โปรเจ็คด้วยคําสัง่ {$R*.RES}  เราสามารถสร้างไฟล์ใหม่ขึน้เองสําหรับเก็บทรัพยากรอ่ืน  เช่น ภาพ

บิตแมพ เคอร์เซอร์ ไอคอน หรือข้อความต่าง ๆ แล้วนํามารวมไว้ในแอพพลิเคชนัด้วยคําสัง่ {$R 

file} นีไ้ด้ 

2.5.5 ไฟล์โปรเจค็กรุ๊ป (Project Group File) 
    

 เป็นไฟล์ท่ีใช้เก็บรวบรวมรายการโปรเจ็คท่ีได้กําหนดไว้ให้อยูใ่นโปรเจ็คกรุ๊ป

เดียวกนั ดงัท่ีจะแสดงให้เห็นในหวัข้อโปรเจ็คเมเนเจอร์ ไฟล์นีจ้ะมีนามสกลุเป็น .bpg และเม่ือเรา

สัง่ Open Project เราก็สามารถเลือกเปิดโปรเจ็คเด่ียว ๆ (ไฟล์นามสกลุ .dpr) หรือเปิดโปรเจ็คกรุ๊ป 

(ไฟล์นามสกลุ .bpg) ได้ 

  

 


